<!DOCTYPE html>
<html lang="en-ZA" class="no-js">
<head>
  <meta http-equiv="content-type" content="text/html; charset=UTF-8">
  <meta name="apple-touch-fullscreen" content="yes"/>
  <meta name="MobileOptimized" content="320"/>
  <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no">
  <link rel="profile" href="http://gmpg.org/xfn/11">
  <title>Forex auction system must be realistic:Ex-Comesa boss &#8211; RadioVop Zimbabwe</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="RadioVop Zimbabwe &raquo; Feed" href="https://www.radiovop.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="RadioVop Zimbabwe &raquo; Comments Feed" href="https://www.radiovop.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RadioVop Zimbabwe &raquo; Forex auction system must be realistic:Ex-Comesa boss Comments Feed" href="https://www.radiovop.com/forex-auction-system-must-be-realisticex-comesa-boss/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.radiovop.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.radiovop.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.8' type='text/css' media='all' />
<link rel='stylesheet' id='foxin-fonts-css'  href='https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700%7COpen%2BSans%3A400%2C600%2C700%2C800&#038;subset' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://www.radiovop.com/wp-content/themes/foxin/style.css?ver=5.6.8' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-css'  href='https://www.radiovop.com/wp-content/themes/foxin/js/magnific/magnific-popup.css?ver=5.6.8' type='text/css' media='all' />
<link rel='stylesheet' id='owl-carousel-css'  href='https://www.radiovop.com/wp-content/themes/foxin/js/owl-carousel/assets/owl.carousel.css?ver=5.6.8' type='text/css' media='all' />
<link rel='stylesheet' id='icon-custom-css'  href='https://www.radiovop.com/wp-content/themes/foxin/css/icon-custom.css?ver=5.6.8' type='text/css' media='all' />
<link rel='stylesheet' id='icon-awesome-css'  href='https://www.radiovop.com/wp-content/themes/foxin/css/font-awesome.css?ver=5.6.8' type='text/css' media='all' />
<link rel='stylesheet' id='base-bootstrap-css'  href='https://www.radiovop.com/wp-content/themes/foxin/css/bootstrap.css?ver=5.6.8' type='text/css' media='all' />
<link rel='stylesheet' id='base-woocoomerce-css'  href='https://www.radiovop.com/wp-content/themes/foxin/css/woocommerce.css?ver=5.6.8' type='text/css' media='all' />
<link rel='stylesheet' id='base-template-css'  href='https://www.radiovop.com/wp-content/themes/foxin/css/template.css?ver=5.6.8' type='text/css' media='all' />
<script type='text/javascript' src='https://www.radiovop.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-content/themes/foxin/js/bootstrap.js?ver=5.6.8' id='bootstrap-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-content/themes/foxin/js/countdown.js?ver=5.6.8' id='countdown-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-content/themes/foxin/js/perfect-scrollbar.jquery.min.js?ver=5.6.8' id='scrollbar-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-content/themes/foxin/js/owl-carousel/owl.carousel.min.js?ver=5.6.8' id='owl-carousel-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-content/themes/foxin/js/magnific/jquery.magnific-popup.min.js?ver=5.6.8' id='magnific-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-content/themes/foxin/js/scroll/jquery.scrollto.js?ver=5.6.8' id='scroll-to-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-content/themes/foxin/js/waypoint.js?ver=5.6.8' id='waypoint-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-content/themes/foxin/js/jquery.cookie.js?ver=5.6.8' id='cookie-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-content/themes/foxin/js/isotope.pkgd.min.js?ver=5.6.8' id='isotope-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-content/themes/foxin/js/jquery.typer.js?ver=5.6.8' id='typer-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-content/themes/foxin/js/main.js?ver=5.6.8' id='main-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-content/themes/foxin/js/woocommerce.js?ver=5.6.8' id='woocommerce-theme-js'></script>
<link rel="https://api.w.org/" href="https://www.radiovop.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.radiovop.com/wp-json/wp/v2/posts/21383" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.radiovop.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.radiovop.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.8" />
<link rel="canonical" href="https://www.radiovop.com/forex-auction-system-must-be-realisticex-comesa-boss/" />
<link rel='shortlink' href='https://www.radiovop.com/?p=21383' />
<link rel="alternate" type="application/json+oembed" href="https://www.radiovop.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.radiovop.com%2Fforex-auction-system-must-be-realisticex-comesa-boss%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.radiovop.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.radiovop.com%2Fforex-auction-system-must-be-realisticex-comesa-boss%2F&#038;format=xml" />
<script> var ajaxurl = "https://www.radiovop.com/wp-admin/admin-ajax.php";</script></head>

<body class="post-template-default single single-post postid-21383 single-format-standard ">
  <div class="wrapper-page"> <!--page-->
        
    <header class=" header-default header-v1">
      <div class="topbar hidden-sm hidden-xs">
   <div class="container">
      <div class="content-inner">
        <div class="left pull-left">
          <ul class="socials">
    

     

     

     

    

    
   
   
   
   
    </ul>        </div>  

         <div class="right pull-right">
            <div class="topbar-meta">
                              <a href="https://www.radiovop.com/forex-auction-system-must-be-realisticex-comesa-boss/" title="Login / Register">Login / Register</a>
                         </div>
         </div>   
      </div>   
   </div>   
</div>      
      <div class="">
        
<div class="header-mobile hidden-lg hidden-md">
  <div class="container">
    <div class="row"> 
     
      <div class="left col-xs-4">
         <div class="hidden-lg hidden-md">
   <div class="canvas-menu gva-offcanvas">
     <a class="dropdown-toggle" data-canvas=".mobile" href="#"><i class="gv-icon-103"></i></a>
   </div>
   <div class="gva-offcanvas-content mobile">
      <div class="close-canvas"><a><i class="gv-icon-8"></i></a></div>
      <div class="wp-sidebar sidebar">
         <div id="gva-mobile-menu" class="navbar-collapse"><ul id="menu-top-navigation" class="nav navbar-nav gva-nav-menu gva-mobile-menu"><li id="menu-item-13888" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13888"><a href="https://www.radiovop.com/./national/">National</a></li>
<li id="menu-item-13889" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13889"><a href="https://www.radiovop.com/./africa/">Africa</a></li>
<li id="menu-item-13890" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13890"><a href="https://www.radiovop.com/./business/">Business</a></li>
<li id="menu-item-13891" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13891"><a href="https://www.radiovop.com/./international/">International</a></li>
<li id="menu-item-13892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13892"><a href="https://www.radiovop.com/./sports/">Sports</a></li>
<li id="menu-item-13893" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13893"><a href="https://www.radiovop.com/./blogs/">Blogs</a></li>
<li id="menu-item-13894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13894"><a href="https://www.radiovop.com/./entertainment/">Entertainment</a></li>
</ul></div>         <div class="after-offcanvas">
                     </div>    
     </div>
   </div>
</div>      </div>

      <div class="center text-center col-xs-4">
        <div class="logo-menu">
          <a href="https://www.radiovop.com/">
            <img src="https://www.radiovop.com/wp-content/themes/foxin/images/logo-mobile.png" alt="RadioVop Zimbabwe" />
          </a>
        </div>
      </div>


        <div class="right col-xs-4">
                    <div class="main-search gva-search">
            <a><i class="gv-icon-52"></i></a>
          </div>
        </div> 
       
    </div>  
  </div>  
</div>        <div class="header-mainmenu hidden-xs hidden-sm">
          <div class="hidden-xs hidden-sm">
   <div class="canvas-menu gva-offcanvas">
     <a class="dropdown-toggle" data-canvas=".default" href="#"><i class="gv-icon-103"></i></a>
   </div>
   <div class="gva-offcanvas-content default">
      <div class="close-canvas"><a><i class="gv-icon-8"></i></a></div>
      <div class="wp-sidebar sidebar">
           
     </div>
   </div>
</div>          
            <div class="container"> 
              <div class="prelative">
                <div class="row">
                  <div class="logo col-lg-2 col-md-2 col-sm-12">
                    <a class="logo-theme" href="https://www.radiovop.com/">
                      <img src="https://www.radiovop.com/wp-content/themes/foxin/images/logo.png" alt="RadioVop Zimbabwe" />
                    </a>
                  </div>

                  <div class="col-sm-10 col-xs-12 pstatic header-right">
                    <div class="content-innter clearfix">
                      <div id="gva-mainmenu" class="pstatic main-menu header-bottom">
                        <div id="gva-main-menu" class="navbar-collapse"><ul id="menu-top-navigation-1" class="nav navbar-nav gva-nav-menu gva-main-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13888"><a href="https://www.radiovop.com/./national/">National</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13889"><a href="https://www.radiovop.com/./africa/">Africa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13890"><a href="https://www.radiovop.com/./business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13891"><a href="https://www.radiovop.com/./international/">International</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13892"><a href="https://www.radiovop.com/./sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13893"><a href="https://www.radiovop.com/./blogs/">Blogs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13894"><a href="https://www.radiovop.com/./entertainment/">Entertainment</a></li>
</ul></div>                      </div>
                    </div>

                    <div class="main-search gva-search">
                      <a><i class="gv-icon-52"></i></a>
                    </div>
                    
                    <div class="mini-cart-header cart-v2">
                        
                    </div> 
                  </div> 
            
                </div>  
              </div>  
            </div>
          </div>  
      </div> 
    </header>
        
    <div id="page-content"> <!--page content-->
      <div class="gva-search-content search-content">
        <a class="close-search"><i class="gv-icon-4"></i></a>
        <div class="search-content-inner">
          <div class="content-inner"><form method="get" class="searchform gva-main-search" action="https://www.radiovop.com/">
	<div class="gva-search">
		<input name="s" maxlength="40" class="form-control input-large input-search" type="text" size="20" placeholder="Search...">
		<span class="input-group-addon input-large btn-search">
			<input type="submit" class="fa" value="&#xf002;" />
		</span>
	</div>
</form>


</div>  
        </div>  
      </div>

<section id="wp-main-content" class="clearfix main-page title-layout-standard">
       
   <div class="custom-breadcrumb " >
            <div class="container">
                   <ol class="breadcrumb"><li><a href="https://www.radiovop.com">Home</a>  / </li> <a href="https://www.radiovop.com/./economy/">Economy</a>  /  <li class="active">Forex auction system must be realistic:Ex-Comesa boss</li></ol>      </div>   
   </div>
      <div class="container">  
    <div class="main-page-content row">
         <div class="content-page col-lg-9 col-md-9 col-sm-12 col-xs-12">      
            <div id="wp-content" class="wp-content clearfix">
                
                    
<article id="post-21383" class="post-21383 post type-post status-publish format-standard hentry category-economy">

	<div class="post-thumbnail">
			</div>	

	<div class="post-content">
		<header class="entry-header">
			<h1 class="entry-title">Forex auction system must be realistic:Ex-Comesa boss</h1>
			<div class="entry-meta">
				<span class="post-format hidden">
					<a class="entry-format" href="">Video</a>
				</span>
									<span class="cat-links"><a href="https://www.radiovop.com/./economy/" rel="category tag">Economy</a></span>&nbsp;&nbsp;|&nbsp;&nbsp;
								<span class="entry-date"><a href="https://www.radiovop.com/forex-auction-system-must-be-realisticex-comesa-boss/" rel="bookmark"><i class="gv-icon-1126"></i><time class="entry-date" datetime="2022-04-01T13:24:41+02:00">1st Apr 2022</time></a></span><span class="line-1">&nbsp;&nbsp;|&nbsp;&nbsp;</span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.radiovop.com/author/admin/" rel="author"><i class="gv-icon-579"></i>admin</a></span></span>
							</div>
		</header>

		<div class="entry-content">
			
<p>By Stephen Chadenga</p>



<p>Former Common Market for Eastern and Southern Africa (Comesa) business council secretary general and past president of the Zimbabwe National Chamber of Commerce, Trust Chikohora has said government needed to employ a more realistic and transparent foreign currency auction system if the exchange rate system is to be stabilised.</p>



<p>&#8220;We have for a long time also been calling for a more transparent and realistic exchange rate on the auction system so that is is really driven by supply and demand,&#8221;Chikohora told Radio VOP while commenting on onetFu ort on Zimbabwe presented last week.</p>



<p>&#8220;There is need for a true rate which is reflective of the market so that the auction system becomes the predominant market with the parallel market on the peripheral.</p>



<p>&#8220;This will to a large extent also help in the long run do away with the parallel market and help the country achieve and exchange rate stability.&#8221;</p>



<p>He said current disprortions in the exchange rate system were failing to stabilise the exchange rate, prices and deal with inflation.</p>



<p>The United States dollar (US$) is currently trading at an average $140 officially while on the parallel market it is around $240.</p>



<p>Chikohora also called on government to use the IMF special drawing rights prudently and transparently to improve the country&#8217;s economic fortunes.</p>



<p>He also said there was need for government to redouble efforts to implement the anti corruption agenda which he said was a big impediment to taming the economic challenges.</p>



<p>&#8220;Corruption is an albatross in the development of the economy,&#8221;he said.</p>



<p>He said there was also need for political reforms which as the political actors dialogue (Polad) they have been pushing for long.</p>
			
		</div><!-- .entry-content -->
	</div>	

	</article><!-- #post-## -->

                

                      <nav class="navigation post-navigation" role="navigation">
        <h1 class="screen-reader-text">Post navigation</h1>
        <div class="nav-links">
          <a href="https://www.radiovop.com/clergyman-in-drive-to-win-1-million-economically-hopeless-souls/" rel="prev"><span class="meta-nav prev"><i class="gv-icon-158"></i>Previous Post</span><span class="title prev">Clergyman in drive to win 1 million “economically hopeless souls”</span></a>        </div>
      </nav>
                  </div>    
         </div>      

         <!-- Left sidebar -->
         
         <!-- Right Sidebar -->
                  <div class="sidebar wp-sidebar sidebar-right col-lg-3 col-md-3 col-xs-12 pull-right">
                           <div class="sidebar-inner">
                  <aside id="search-2" class="widget clearfix widget_search"><form method="get" class="searchform gva-main-search" action="https://www.radiovop.com/">
	<div class="gva-search">
		<input name="s" maxlength="40" class="form-control input-large input-search" type="text" size="20" placeholder="Search...">
		<span class="input-group-addon input-large btn-search">
			<input type="submit" class="fa" value="&#xf002;" />
		</span>
	</div>
</form>


</aside>
		<aside id="recent-posts-2" class="widget clearfix widget_recent_entries">
		<h3 class="widget-title"><span>Recent Posts</span></h3>
		<ul>
											<li>
					<a href="https://www.radiovop.com/forex-auction-system-must-be-realisticex-comesa-boss/" aria-current="page">Forex auction system must be realistic:Ex-Comesa boss</a>
									</li>
											<li>
					<a href="https://www.radiovop.com/clergyman-in-drive-to-win-1-million-economically-hopeless-souls/">Clergyman in drive to win 1 million “economically hopeless souls”</a>
									</li>
											<li>
					<a href="https://www.radiovop.com/women-politicians-urged-to-use-media-effectively-during-elections/">Women politicians urged to use media effectively during elections</a>
									</li>
											<li>
					<a href="https://www.radiovop.com/prayerful-ethel-sibandas-book-instils-hope-faith-after-loss/">Prayerful Ethel Sibanda’s book instils hope, faith after loss</a>
									</li>
											<li>
					<a href="https://www.radiovop.com/davido-other-things-excite-nigerian-afrobeats-star-more-than-music/">Davido: Other things excite Nigerian Afrobeats star more than music</a>
									</li>
					</ul>

		</aside>               </div>
                     </div>
               </div>   
    </div>
    </section>

	</div><!--end page content-->
	<div id="gva-overlay"></div>
</div><!-- End page -->

	<footer id="wp-footer" class="clearfix">
						<div class="copyright">
			<div class="container">
				<div class="row">
					<div class="col-sm-8 col-xs-12">
						Copyright2022 - Company - All rights reserved. Powered by WordPress.					</div>
					<div class="col-sm-4 col-xs-12">
						<ul class="socials">
    

     

     

     

    

    
   
   
   
   
    </ul>					</div>
				</div>	
			</div>
		</div>
		
		<div id="gva-quickview" class="clearfix"></div>

		<div class="return-top default"><i class="gv-icon-194"></i></div>

	</footer>
	
<script type='text/javascript' src='https://www.radiovop.com/wp-includes/js/comment-reply.min.js?ver=5.6.8' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' src='https://www.radiovop.com/wp-includes/js/wp-embed.min.js?ver=5.6.8' id='wp-embed-js'></script>
</body>
</html>